Agent Installation Prerequisites

 Windows Installation Prerequisites for Agent

You can download the Windows installer file in your assessment from the Agent Setup > Assess tab. You can download the MSI file or copy the command to be run from an elevated command prompt. The command pictured below shows options for a proxy server with authentication required. These options are also available in the MSI file but not required to install the agent.

  • Access to our servers 104.197.11.97 for US infrastructure and 35.198.133.35 for EU infrastructure over port 443 either directly or through a corporate proxy 
  • One of the following OSes:
    • Windows Server 2019
    • Windows Server 2016
    • Windows Server 2012 R2
    • Windows Server 2008 R2 **
  • .NET framework version 4.0
  • 320 MB persistent storage

Server Core for each of the above OSs is also supported

**Best Effort, product has reached EOL

The Cloudamize Machine Agent requires .2% of available CPU and 3% of memory while running. If the agent takes more than the allotted CPU and memory the watchdog process will stop the agent process and begin again once it's able to run below the thresholds. 

Windows installation and troubleshooting Procedures can be found here.

 

  

Linux Installation Prerequisites for Agent

You can access the Linux installer command and customer key in your assessment from the Agent Setup > Assess tab. The command pictured below shows options for a proxy server with authentication required. These options are not required and can be installed without a corporate proxy provided port 443 is open to our data collection server.

 

  • The Install script requires wget to retrieve content, and curl to test/verify access to our data collection servers 104.197.11.97 for US infrastructure and 35.198.133.35 for EU infrastructure over port 443, either directly or through a corporate proxy
  • Root and/or wheel access
  • One of the following OSes:
    • Red Hat Enterprise Linux Server release 6.0 or higher (RHEL 5.0 is supported on a best effort basis)
    • Oracle Linux 6.5 or higher
    • Ubuntu 10.04 or higher
    • CentOS release 5 or higher
    • Debian GNU/Linux 6.0 or higher
    • Amazon Linux AMI release 2013.03 or higher
    • Fedora release 12 or higher
    • Suse Linux 11 or higher
  • OpenSSL v1.0 or higher
  • Root and/or wheel access
  • 350 MB persistent storage
  • The Install script requires wget to retrieve content, and curl to test/verify access to our data collection servers (104.197.11.97) over port 443, either directly or through a corporate proxy

 

The Cloudamize Linux Agent requires 3% of available CPU and 5% of memory while running. If the agent takes more than the allotted CPU and memory the watchdog process will stop the agent process and begin again once it's able to run below the thresholds. 

 Linux installation and troubleshooting Procedures can be found here.

 

  

Supported Chipsets for all installation types

  • Intel Xeon
  • AMD Opteron
  • Pentium 4
  • Pentium D
  • Pentium M
  • Some Intel Core 2 **

**Best effort will be given to support these chipsets

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.